AKLWEB HOST LLC
 

Data Center Power Failure Monday 1st June 2026 09:03:00


Investigating: Data Center Power Failure

We are currently experiencing a power failure affecting our data center infrastructure. As a result, some services may be unavailable or experience intermittent disruptions.

Our technical teams are actively investigating the issue and working to restore full operations as quickly as possible. We will continue to provide updates as more information becomes available.

We apologize for any inconvenience this may cause and appreciate your patience and understanding.

Identified: Clay building Sustained Damage

“Early this morning, our facilities sustained a direct hit from a tornado. The Clay building sustained damage sufficient to disrupt power. At this time we've restored power to 50% of our dedicated server customers. We are continuing to work to restore the remaining service. ETA is 2 hours.

Both buildings sustained minor damage, however, only customers in the Clay building were affected. Colocation customers in the Swift facility experienced no disruption in services.

We appreciate your patience and understanding as we work to fully restore service.”

Copyright © 2026 AKLWEB HOST LLC. All Rights Reserved.